This renames a couple of functions and members (no functional changes, expect log prints):
- Rename CKey::SetMaster to CKey::SetSeed
- Rename CHDChain::masterKeyId to CHDChain::seedKeyID
- Rename CHDChain::hdMasterKeyID to CHDChain::hdSeedKeyID
- Rename CWallet::GenerateNewHDMasterKey to CWallet::GenerateNewHDSeedKey
- Rename CWallet::SetHDMasterKey to CWallet::SetHDSeedKey
As well it introduces a tiny API change (a649ab2):
- RPC API change: Rename “hdmasterkeyid” to “hdseedkeyid”, rename “hdmaster” in wallet-dump output to “hdseed”
Fixes also a bug (16d49e1):
- Bugfix: use “s” instead of the incorrect “m” for the seed-key hd-keypath key metadata