This PR is to address follow-ups for #24584, specifically:
- Remove redundant, hard-to-read code by adding a new
OutputType
and adding shuffle, erase, and push_back methods forCoinsResult
- Add missing
BOOST_ASSERT
to unit test - Ensure functional test only runs if using descriptor wallets
- Improve readability of
AttemptSelection
by removing triple-nested if statement
Note for reviewers: commit refactor: add new helper methods
should throw an “unused function warning”; the function is used in the next commit. Also, commit wallet: switch to new shuffle, erase, push_back
will fail to compile, but this is fixed in the next commit with a scripted-diff. the commits are separate like this (code change then scripted-diff) to improve legibility.