The term “force” is ambiguous and not used in BIP9 where there ! rule prefix is introduced.
E.g. this code is hard to read:
0if (!gbt_force) {
1 s.insert(s.begin(), '!');
Additionally, #29039 renamed gbt_vb_name
to gbt_force_name
which, at least for me, further increased the confusion.
This is a pure (variable rename) refactor (plus documentation) and does not change behavior.
Reminder of how to verify a scripted diff:
0test/lint/commit-script-check.sh origin/master..HEAD