This PR changes developer notes to suggest naming instance methods with lowerCamelCase()
, and other functions with UpperCamelCase()
.
Lower camel case names were allowed by the developer guide before #10917, and are used in a good amount of existing code.
Using lower camel case to distinguish instance method calls from other types of calls can aid with code readability and review. Seeing a lowerCase()
call would tell you that an implicit this
pointer is being passed, and could be a signal during code review that a call has access to more information than needs, or may not be doing exactly what you think it does.
Using a distinct style for instance method names is also analagous with our existing convention for using m_
prefixes in instance member variable names.