jnewbery
commented at 4:13 pm on August 19, 2019:
member
CheckInputs() used to check no double spends, scripts & sigs and amounts. Since
832e074, the double spend and amount checks
have been moved to CheckTxInputs(), and CheckInputs() now just validates
input scripts. Rename the function to CheckInputScripts().
Also fix incorrect comments.
jnewbery
commented at 4:13 pm on August 19, 2019:
member
This builds on #13868. Please review that PR first.
DrahtBot added the label
Tests
on Aug 19, 2019
DrahtBot added the label
Validation
on Aug 19, 2019
DrahtBot
commented at 6:29 pm on August 19, 2019:
member
The following sections might be updated with supplementary metadata relevant to reviewers and maintainers.
Conflicts
Reviewers, this pull request conflicts with the following ones:
#17399 (validation: Templatize ValidationState instead of subclassing by jkczyz)
If you consider this pull request important, please also help to review the conflicting pull requests. Ideally, start with the one that should be merged first.
jnewbery force-pushed
on Aug 25, 2019
jnewbery renamed this:
[validation] Rename CheckInputs to CheckInputScripts
validation: Rename CheckInputs to CheckInputScripts
on Aug 25, 2019
jnewbery renamed this:
validation: Rename CheckInputs to CheckInputScripts
[WIP] validation: Rename CheckInputs to CheckInputScripts
on Aug 26, 2019
fanquake
commented at 2:39 am on September 2, 2019:
member
Concept ACK
This builds on #13868. Please review that PR first.
This needs a couple functional test changes for the expected messages.
Fixed. Thanks.
Should 046cd75 be a scripted-diff?
I think this is small enough to be a non-scripted commit, and I’d need to add more to your suggested one-liner to make the test changes atomic with the validation.cpp changes. I’m leaving as it is for now, but can change if other reviewers agree that scripted would be better.
DrahtBot removed the label
Needs rebase
on Sep 2, 2019
ajtowns
commented at 11:57 am on September 3, 2019:
member
I’d need to add more to your suggested one-liner to make the test changes atomic with the validation.cpp changes
FWIW, I believe a valid scripted-diff line for 3623a8f946c55c3fd897a057ac38acb85817f593 would be:
1280@@ -1284,8 +1281,10 @@ void InitScriptExecutionCache() {
1281 }
12821283 /**
1284- * Check whether all inputs of this transaction are valid (no double spends, scripts & sigs, amounts)
1285- * This does not modify the UTXO set.
1286+ * Check whether all of this transaction's input scripts succeed.
1287+ *
1288+ * This involves ECDSA signature checks so can be computationally intensive. This function should
1289+ * only be called after the basic tx amount tests in CheckTxInputs passed.
MarcoFalke
commented at 8:05 pm on September 3, 2019:
This seems to imply that when the basic tx amount tests pass, the amount fields in the tx are correct. However, you can only know that the amount fields are correct when all subsequent check (including signature checks have been run). I’d rather say something like “all cheap sanity checks passed”, to be not overly specific.
jnewbery
commented at 10:32 pm on September 4, 2019:
agree. Fixed
jnewbery force-pushed
on Sep 4, 2019
jnewbery
commented at 10:32 pm on September 4, 2019:
member
FWIW, I believe a valid scripted-diff line for 3623a8f would be…
I’ve updated the commit to use your scripted diff one-liner. Thanks!
michaelfolkson
commented at 12:49 pm on September 7, 2019:
contributor
Concept ACK. I ran a git grep on CheckInputs in this PR branch and apart from old release notes that obviously won’t change, there is a ValidateCheckInputsForAllFlags function in src/test/txvalidationcache_tests.cpp, a CheckInputsAndUpdateCoins function in src/txmempool.cpp and CheckInputsFromMempoolAndCache function in src/validation.cpp. Should they be changed too?
fanquake
commented at 8:10 am on September 8, 2019:
member
@jnewbery Looks like the scripted diff needs fixing:
0$ set -o errexit; source ./ci/lint/06_script.sh
1Error: script block marker but no scripted-diff in title
2Failed
jnewbery
commented at 2:59 pm on September 8, 2019:
member
Looks like the scripted diff needs fixing
Thanks. Will fix next week.
jnewbery force-pushed
on Sep 10, 2019
jnewbery
commented at 12:56 pm on September 10, 2019:
member
Looks like the scripted diff needs fixing
should be fixed
DrahtBot added the label
Needs rebase
on Sep 18, 2019
jnewbery force-pushed
on Oct 1, 2019
jnewbery
commented at 2:18 pm on October 1, 2019:
member
rebased
DrahtBot removed the label
Needs rebase
on Oct 1, 2019
MarcoFalke
commented at 7:21 pm on October 11, 2019:
member
ACK3ee9ad76803c0f9fdcb21ac1ad6162df79df07da thanks for fixing documentation
promag
commented at 3:55 pm on October 25, 2019:
member
TIL git grep -l CheckInputs -- ':!doc'.
Code review ACK.
DrahtBot added the label
Needs rebase
on Oct 30, 2019
jnewbery force-pushed
on Oct 30, 2019
jnewbery
commented at 4:47 pm on October 30, 2019:
member
Rebased on master
DrahtBot removed the label
Needs rebase
on Oct 30, 2019
DrahtBot
commented at 4:31 pm on November 7, 2019:
member
DrahtBot added the label
Needs rebase
on Nov 7, 2019
MarcoFalke
commented at 5:18 pm on November 7, 2019:
member
This is a trivial fix that should be ready for merge after rebase
scripted-diff: [validation] Rename CheckInputs to CheckInputScripts
CheckInputs() used to check no double spends, scripts & sigs and amounts. Since
832e0744cb8b1e1625cdb19b257f97316ac16a90, the double spend and amount checks
have been moved to CheckTxInputs(), and CheckInputs() now just validates
input scripts. Rename the function to CheckInputScripts().
-BEGIN VERIFY SCRIPT-
sed -i -E -e 's/CheckInputs\b/CheckInputScripts/g' $(git grep -l CheckInputs | grep -v doc/)
-END VERIFY SCRIPT-
6f6465cefc
[validation] fix comments in CheckInputScripts()3bd8db80d8
jnewbery force-pushed
on Nov 7, 2019
jnewbery
commented at 6:53 pm on November 7, 2019:
member
Rebased
fanquake removed the label
Needs rebase
on Nov 7, 2019
MarcoFalke
commented at 7:04 pm on November 7, 2019:
member
re-ACK3bd8db80d8d335ab63ece4f110b0fadd562e80b7, did the rebase myself, checked the scripted diff 👡
Signature:
0-----BEGIN PGP SIGNED MESSAGE-----
1Hash: SHA512
2 3re-ACK3bd8db80d8d335ab63ece4f110b0fadd562e80b7, did the rebase myself, checked the scripted diff 👡
4-----BEGIN PGP SIGNATURE-----
5 6iQGzBAEBCgAdFiEE+rVPoUahrI9sLGYTzit1aX5ppUgFAlwqrYAACgkQzit1aX5p
7pUjh4wv/WSY4eMrYXocYlXm6kXbisKRQM+4z5HS9drtint6Mf3u/Zj3zioAxEApI
8sIk6tuwzracrSYy2D6YtZnSSjpMwrtCRYy48OOt8e0WDnlUpZwTUyjCwp+l4nsMa
9Bc+MUtTe9Eq8ICEAyFbNVGr+yvt18WlqM/h5DEIchFlGIE76BajPBTRxnf1QVe5o
10OiC7ErXnpj79LzBYP5MF8/R7AMb66y+++Xop9pZeMkLAWM//0exTlsGrJU7V/GJW
112Mx/wApRUFjTz/NNDl5iArpayOa7KFcPZ9MhzvfBV0v+vihH3HzDKmvT9NYTDgox
126WvsBr1nj2F1ONV/fZQ9h8SK0jj4ewguDgNJ8cwB2uJQBqUOaWayNNNbE1egJIOv
1333VpHuFdUIHsuRJMufZPpuNrK2/h0HguHVunuIM8jIvdG0dt+ioFYabXmKkywPi8
14EQjw/j4DyvGzKILVKFpHatAFHLET87oGMH2Ph7ComQKOmYjsuyXvnys04y6KOwlg
154n7UJzLs
16=3RbB
17-----END PGP SIGNATURE-----
This is a metadata mirror of the GitHub repository
bitcoin/bitcoin.
This site is not affiliated with GitHub.
Content is generated from a GitHub metadata backup.
generated: 2024-11-17 12:12 UTC
This site is hosted by @0xB10C More mirrored repositories can be found on mirror.b10c.me