Chainparams: Wallet: Decouple DefaultFallbackfee() from IsTestChain() #16771

pull jtimon wants to merge 1 commits into bitcoin:master from jtimon:b19-chainparams-fallbackfee changing 5 files +28 −21
  1. jtimon commented at 3:59 pm on August 31, 2019: contributor

    This doesn’t change functionality beyond improving the –help tdocumentation.

    Together with #16770 , this allows to get rid of Params().IsTestChain().

    This is an alternative to #16524 , which, for example @instagibbs doesn’t seem to like very much.

  2. DrahtBot added the label Validation on Aug 31, 2019
  3. DrahtBot added the label Wallet on Aug 31, 2019
  4. DrahtBot commented at 5:00 pm on August 31, 2019: member

    The following sections might be updated with supplementary metadata relevant to reviewers and maintainers.

    Conflicts

    Reviewers, this pull request conflicts with the following ones:

    • #16770 (Chainparams: Decouple AllowAcceptNonstd() from IsTestChain() by jtimon)
    • #16527 (B: Get rid of Params().RequireStandard() by jtimon)
    • #16526 (A: Chainparams: Rename RequireStandard() to DefaultAcceptNonstd() by jtimon)
    • #16524 (Wallet: Disable -fallbackfee by default by jtimon)

    If you consider this pull request important, please also help to review the conflicting pull requests. Ideally, start with the one that should be merged first.

  5. DrahtBot added the label Needs rebase on Sep 3, 2019
  6. jtimon force-pushed on Sep 6, 2019
  7. DrahtBot removed the label Needs rebase on Sep 7, 2019
  8. Chainparams: Wallet: Decouple DefaultFallbackfee() from IsTestChain() 46c835f467
  9. in src/wallet/wallet.cpp:4436 in e7865a8039 outdated
    4444+    }
    4445+    walletInstance->m_fallback_fee = CFeeRate(nFeePerK);
    4446+    walletInstance->m_allow_fallback_fee = nFeePerK != 0; //disable fallback fee in case value was set to 0, enable if non-null value
    4447+
    4448     if (gArgs.IsArgSet("-discardfee")) {
    4449         CAmount nFeePerK = 0;
    


    practicalswift commented at 4:40 pm on September 28, 2019:
    This nFeePerK is shadowing the nFeePerK in the outer scope.

    jtimon commented at 7:19 pm on September 28, 2019:
    Yes, it is. And more of the same below. But in every use of their own nFeePerK they initialize it. Anyway, what do you think I should do? Perhaps just rename the variable? any suggestion on the name?

    practicalswift commented at 9:27 am on September 29, 2019:
    I would use another variable name to disambiguate :)

    jtimon commented at 4:05 pm on October 2, 2019:
    Fixed nit, renamed to fee_per_k.
  10. jtimon force-pushed on Oct 2, 2019
  11. jtimon commented at 7:01 pm on October 2, 2019: contributor
    Closing since competing #16524 was merged instead.
  12. jtimon closed this on Oct 2, 2019

  13. jtimon deleted the branch on Oct 2, 2019
  14. MarcoFalke locked this on Dec 16, 2021

github-metadata-mirror

This is a metadata mirror of the GitHub repository bitcoin/bitcoin. This site is not affiliated with GitHub. Content is generated from a GitHub metadata backup.
generated: 2024-07-05 19:13 UTC

This site is hosted by @0xB10C
More mirrored repositories can be found on mirror.b10c.me