This is a follow-up PR to #18533, which changed the naming of strCommand
to msg_type
in the network processing code. The same approach is done here for the function test framework, to get rid of the wrong “command” terminology for network mesage types. (Commands are usually used in the CLI or RPC context, so using the same name in the network message context would only be confusing.)
The commit was created through the following steps:
- search for all occurences of the string “command” within the folder
test/functional
git grep -i command test/functional > command_finds
- manually sort out all false-positives, i.e. occurences of “command” which describe commands in the correct sense (mostly CLI or RPC related, also some with Socks5)
- put the remaining occurences into a scripted-diff (a quite simple one, actually) that renames “command” to “msgtype” in the concerned files.
The name msgtype
was intentionally chosen without the underscore _
as classes beginning with msg_
define concrete types of messages.