43@@ -44,8 +44,8 @@ UniValue ValueFromAmount(const CAmount amount);
44 std::string FormatScript(const CScript& script);
45 std::string EncodeHexTx(const CTransaction& tx, const int serializeFlags = 0);
46 std::string SighashToStr(unsigned char sighash_type);
47-void ScriptPubKeyToUniv(const CScript& scriptPubKey, UniValue& out, bool fIncludeHex, bool include_addresses);
48-void ScriptToUniv(const CScript& script, UniValue& out, bool include_address);
49-void TxToUniv(const CTransaction& tx, const uint256& hashBlock, bool include_addresses, UniValue& entry, bool include_hex = true, int serialize_flags = 0, const CTxUndo* txundo = nullptr);
50+void ScriptPubKeyToUniv(const CScript& scriptPubKey, UniValue& out, bool include_hex, bool include_address = true);
51+inline void ScriptToUniv(const CScript& script, UniValue& out) { ScriptPubKeyToUniv(script, out, /* include_hex */ true, /* include_address */ false); }
6604cdcccd maybe I’m missing something but perhaps merge ScriptPubKeyToUniv
and ScriptToUniv
into a single function?
I thought about it (and agree it’s a good change). However I didn’t include it originally because I wanted to be conservative w/ the changes in this PR and thought keeping them as separate functions may have been “self documenting”
Anyways, I wanted to do this and since you were thinking the same thing I did it in this commit b456004de9ef61716140c9020c572416b46acbff - if we decide we don’t want it I can just revert this commit