interfaces::WalletClient
was different from interfaces::Wallet
.
interfaces::WalletClient
was different from interfaces::Wallet
.
Name has been confusing since it was introduced, and it was pointed in
recent review club as https://bitcoincore.reviews/10102 that it was
particularly unclear how interfaces::WalletClient was different from
interfaces::Wallet.
-BEGIN VERIFY SCRIPT-
ren() { git grep -l "$1" src | xargs sed -i "s/$1/$2/g"; }
ren WalletClient WalletLoader
ren walletClient walletLoader
ren wallet_client wallet_loader
ren "wallet clients release the wallet" "wallet pointer owners release the wallet"
ren "wallet client" "wallet loader"
ren "Wallet client" "Wallet loader"
-END VERIFY SCRIPT-
The following sections might be updated with supplementary metadata relevant to reviewers and maintainers.
Reviewers, this pull request conflicts with the following ones:
gArgs
from bdb.h
and sqlite.h
by kiminuo)src/node/
and src/wallet/
code to node::
and wallet::
namespaces by ryanofsky)If you consider this pull request important, please also help to review the conflicting pull requests. Ideally, start with the one that should be merged first.
Concept ACK - WalletLoader is improved naming imo.
Checked there were no remaining references to WalletClient on master after this PR.
ACK ff5f6de
WalletLoader
is really a better name for this class.
Concept ACK
WalletLoader
is a definite name improvement over WalletClient
, considering the purpose of this class.
…also has additional //! methods (called by the GUI) to load and create wallets.
I checked for any more occurrences of WalletClient in PR, and I found none. I was able to compile and run bitcoind successfully on Ubuntu 20.04.
However, I would still like to wait for other reviewers’ views on this change before giving an ACK.