This didn’t accomplish what I hoped, but maybe worth including as a refactor anyway.
There’s obviously further improvement possible, but this already seems like quite a bit for one refactoring step.
This didn’t accomplish what I hoped, but maybe worth including as a refactor anyway.
There’s obviously further improvement possible, but this already seems like quite a bit for one refactoring step.
This didn’t accomplish what I hoped…
What do you hope?
What do you hope?
I’d like the new “signmessage for p2pkh only” to only show if there are actually non-p2pkh addresses being hidden.
🐙 This pull request conflicts with the target branch and needs rebase.
Want to unsubscribe from rebase notifications on this pull request? Just convert this pull request to a “draft”.
88@@ -88,7 +89,8 @@ class AddressTablePriv
89 QString::fromStdString(address.purpose), address.is_mine);
90 cachedAddressTable.append(AddressTableEntry(addressType,
91 QString::fromStdString(address.name),
92- QString::fromStdString(EncodeDestination(address.dest))));
93+ QString::fromStdString(EncodeDestination(address.dest)),
94+ (address.dest.type() == typeid(PKHash))));
6604abe6ab25925b379b3f16630906de3aaf51fb
I think you could do std::get_if<PKHash>(address.dest) != nullptr
. Same below, and drop <typeinfo>
header.
nit, commit prefix should be qt
?
149@@ -145,14 +150,14 @@ AddressBookPage::~AddressBookPage()
150 delete ui;
151 }
152
153-void AddressBookPage::setModel(AddressTableModel *_model)
154+void AddressBookPage::setModel(AddressTableModel *_model, const bool p2pkh_only)
86be9e4a353f8c2ab35c3c1177e8ad63b8e50eab
nit, this could be renamed AddressBookPage::setupModel(AddressTableModel* source_model, const bool p2pkh_only)
. Alternatively these could be passed in AddressBookPage
constructor and this method would be private.