We have a bunch of secp256k1_ec_privkey_
functions but then we have secp256k1_ec_seckey_verify
. I think we should create a privkey
alias for this function.
More generally, we sometimes write “private key” and sometimes “secret key”, and all the privkey
functions expect a seckey
argument. This should be made consistent too.