We should have a naming convention for function arguments that are considered secret by the function (w.r.t to the side channels). This could for example be a prefix, a suffix, or uppercase.
This will be helpful as documentation for the API functions at least.
I’m not sure if it’s worth the hassle for the internal functions. Clearer docs certainly won’t hurt, but our constant-time tests should catch any violation of secrecy constraints (if nicely documented or not).