This is meant to improve readability of code and remove guesswork needed to determine argument types and migrate to typed arguments (#22978) by having distinctly named GetArg
GetArgs
GetBoolArg
and GetIntArg
methods.
This commit was originally part of #22766 and had some review discussion there. But it was wisely suggested to be split off to make that PR smaller.