Fixes #645.
Add getrawtransaction
RPC to GUI on Tools -> Verify external txid.
tab
Fixes #645.
Add getrawtransaction
RPC to GUI on Tools -> Verify external txid.
tab
The following sections might be updated with supplementary metadata relevant to reviewers and maintainers.
See the guideline for information on the review process.
Type | Reviewers |
---|---|
ACK | pablomartin4btc, alfonsoromanz |
Concept ACK | hernanmarino, kristapsk, hebasto |
If your review is incorrectly listed, please react with 👎 to this comment and the bot will ignore it on the next update.
No conflicts as of last run.
Cool, that’s pretty nice!
Just thinking out loud, but it does make me wonder if perhaps a new Verify
or Utils
button, in line with “Send | Recieve | Transactions” could be even nicer? If we added it there, we might consider adding a few more utils to the GUI like “Decode raw transaction”, “Decode Script”, “Get Descriptor Info”, “Verify Message” etc. which folks who use the gui generally use other software for today…
Cool, that’s pretty nice!
Just thinking out loud, but it does make me wonder if perhaps a new
Verify
orUtils
button, in line with “Send | Recieve | Transactions” could be even nicer? If we added it there, we might consider adding a few more utils to the GUI like “Decode raw transaction”, “Decode Script”, “Get Descriptor Info”, “Verify Message” etc. which folks who use the gui generally use other software for today… @willcl-ark would love to hear more opinions on this, I also thinkHelp -> Verify external txid
tab might not work well with adding more utils
Yeah I don’t want to derail this pr, which I think looks good on its own!
If there was desire to add more utils we could always move this later; I think this looks nice.
124+ ui->txidEdit->setVisible(false);
125+ ui->labelBlockHash->setVisible(false);
126+ ui->blockHashEdit->setVisible(false);
127+ ui->submitButton->setVisible(false);
128+ ui->verboseCheckbox->setVisible(false);
129+ break;
initializeAboutModeWindow
” or something like that, same for the other modes, making the code a bit more maintainable and easier to follow.
Concept ACK
As @luke-jr perhaps we can create a separate menu item like “Tools” or “Utils” with this feature in it (and would be more suitable if we need to add for example other features as @willcl-ark mentioned).
Light CR.
Add getrawtransaction RPC to GUI to tools > getrawtransactions
I have updated the PR based on the feedback given above:
Tools
menugetrawtransaction RPC
implementation to Tools > verify external txid
19+ <number>12</number>
20+ </property>
21+ <item row="0" column="0">
22+ <widget class="QLabel" name="labelTxId">
23+ <property name="text">
24+ <string>transaction id: </string>
nit:
0 <string>Transaction id: </string>
or ID
?
49+ </widget>
50+ </item>
51+ <item row="2" column="0">
52+ <widget class="QLabel" name="labelBlockHash">
53+ <property name="text">
54+ <string>blockhash (optional): </string>
nit:
0 <string>Blockhash (optional): </string>
368@@ -368,12 +369,17 @@ void BitcoinGUI::createActions()
369 m_mask_values_action->setStatusTip(tr("Mask the values in the Overview tab"));
370 m_mask_values_action->setCheckable(true);
371
372+ getRawTransactionAction = new QAction(tr("&Verify external txid"), this);
nit:
0 getRawTransactionAction = new QAction(tr("&Verify transaction"), this);
Some thoughts: perhaps we use a more generic naming here and in the form we indicate if it’s a wallet transaction with a checkbox (and then we change the form removing the blockhash option and call gettransaction
?). Or maybe just on a follow-up.
utACK 9659890f7c9223d85dda3d066c2e3de42cabe7cf
I agree that the new place for this PR’s feature looks better under the new “Tools” menu.
Also code-wise it’s better to have a new separate dialog (toolsdialog
) rather than re-using the existing help dialog (HelpMessageDialog
). Thinking it loud, I wonder if we need to specify a more specific name instead of the current generic one (what other use cases would open this ToolsDialog
? Other RPC commands?). Another thoughts: how this new feature (and future ones?) integrates with the current RPC console? Should we also have some kind of link on the form to open the console with the execution of the rpc command and its output? Should we create a new sub-menu under “Tools” like “RPC commands”? These are some questions that don’t need to be answered right now nor stopping this PR to go ahead and get merged, just to keep the focus on what directions we want to give to the UI and follow it up.
Concept ACK. However, I still agree with @promag’s https://github.com/bitcoin/bitcoin/issues/19161#issuecomment-667726216:
GUI users can use the RPC console.
Seems confusing to have the same feature present twice. Once in this pop-up and another time in the RPC pop-up?
If this is merged, then every RPC will be duplicated in a new GUI pop-up?
🐙 This pull request conflicts with the target branch and needs rebase.