This PR is an attempt at tidying up test util functions, as suggested in #1491. The following changes are done:
- rename
_group_element...
functions to_ge...
- rename
_field_element...
functions to_fe...
- move
random_
helpers from tests.c to testutil.h (the alternative would be testrand.h, but to my understanding, this one is meant to contain the actual RNG implementation rather than helpers using it; happy to move the helpers there if that is preferred though) - prefix testutil.h functions with
testutil_
- prefix testrand.h functions with
testrand_
(this is currently done in a sloppy way by simply dropping thesecp256k1_
prefix, so some functions don’t have the full prefix, like e.g.testrand256
; naming suggestions welcome)