Scripted diff to rename some wallet classes. Motivated by discussion in #11687 (review)
Current | New |
---|---|
CDBEnv | BerkeleyEnvironment |
CDB | BerkeleyBatch |
CWalletDBWrapper | WalletDatabase |
CWalletDB | WalletBatch |
Berkeley* classes are intended to contain BDB specific code, while Wallet* classes are intended to be more backend-agnostic.
Also renamed associated variables:
Current | New |
---|---|
dbw | database |
pwalletdb | batch |
pwalletdbEncryption | encrypted_batch |