344@@ -340,6 +345,7 @@ std::string HelpMessage(HelpMessageMode mode)
345 strUsage += HelpMessageOpt("-sysperms", _("Create new files with system default permissions, instead of umask 077 (only effective with disabled wallet functionality)"));
346 #endif
347 strUsage += HelpMessageOpt("-txindex", strprintf(_("Maintain a full transaction index, used by the getrawtransaction rpc call (default: %u)"), DEFAULT_TXINDEX));
348+ strUsage += HelpMessageOpt("-txoutsbyaddressindex", strprintf(_("Maintain an address to unspent outputs index (rpc: gettxoutsbyaddress). The index is built on first use. (default: %u)"), 0));
My personal preference would be something shorter like "txoutsindex"
, especially because it really indexes scripts and not addresses.
Sure I dont see a problem with that
Or just txoutindex
(or utxoutindex
or utxoindex
)
argh, paradox of choice!
Ok, how about if nobody has any objection I will change the name to “txoutindex” (command line parameter, RPC, REST etc)?